Alpha client Mac

Whenever I want to open the game after previously quitting it (CMD +Q), the client just bugs out and nothing really happens so I'm forced to restart the whole laptop just to open up the client. Anyone having any similar problems? I run on 10.7.5

Posts are displayed here in chronological (time, oldest first, newest last) order, like a regular web forum.

Do you "logout"(click the x) or Quit the application (CMD + Q) and does it work with the other way???? I am on a mac as well and I do NOT have this issue, I just tried to quit out and it asked me if I wanted to log out. Maybe try to repair the client. MacBook Pro (Retina, 15-inch, Mid 2015) mac OS 10.12.2 Beta
Ok think I may have replicated your issue, I Force Quit (not CMD + Q) out of League and now I can not get it to launch via the shortcut. I think my issue is by force quitting the application, The "lockfile" never got deleted. Try to open one of these files /Applications/League of Legends.app/Contents/LoL/LeagueClient /Applications/League of Legends.app/Contents/LoL/Play League of Legends The first is the link to the Alpha client, the second is the link to the legacy client. If that does not work, try opening up one of the links inside one of the deploy folders: /Applications/League of Legends.app/Contents/LoL/RADS/projects/league_client/releases/ open up on of the "0.0." files, then go into /deploy/ click on "LeagueClient" Opening up from there worked after I was getting locked out Let me know if that helps.

This is a fanmade archive of the leagcy League of Legends forums/boards. LeagueBoards.net isn't endorsed by Riot Games and doesn't reflect the views or opinions of Riot Games or anyone officially involved in producing or managing League of Legends. League of Legends and Riot Games are trademarks or registered trademarks of Riot Games, Inc. League of Legends © Riot Games, Inc.